您所在的位置:我要培训 > 2010年软考网络工程师试题及答案解析

2010年软考网络工程师试题及答案解析

2010-09-02 16:24 佚名 比特网 字号:T | T
一键收藏,随时查看,分享好友!

以下的文章主要向大家讲述的是2010年软考网络工程师模拟试题以及答案的正确解析,以下就是文章的主要内容的详细描述。

AD:

此文主要向大家描述的是2010年软考网络工程师模拟试题以及对其正确案的解析。

[导读]2010年软考网络工程师模拟试题及答案解析(下午题)

● 试题一

随着Internet的发展,用户对网络带宽的要求不断提高,传统的接入网已成为整个网络中的瓶颈,以新的宽带接入技术取而代之已成为目前研究的焦点。其中最引人注意的是光纤接入技术。

[问题1]

FTTH有哪两种实现技术?

[问题2]

什么是PON,请列举影响EPON的关键技术?

● 试题一

[问题1]

【答案】有APON和EPON两种实现技术。

[问题2]

【答案】PON(无源光网络)技术是一种点对多点的光纤传输和接入技术,下行采用广播方式,上行采用时分多址方式,可以灵活的组成树型、星型。总线型等拓扑结构。

影响EPON的关键技术有:上行信道复用技术、测距和时延补偿技术;光器件的发展、突发信号的快速同步、下行信道的安全性,如何实现Qos和如何实现VLAN与网络管理等。

● 试题二

阅读以下有关网络规划的叙述,回答问题1、问题2和问题3,把解答填入答题纸的对应栏内。

网络工程是一项复杂的系统工程,一般可分为网络规划、网络设计、工程实施、系统测试验收和运行维护等几个阶段。网络规划是在需求分析的基础上,进行系统可行性分析和论证,以确定网络总体方案。网络规划阶段任务完成之后转入下一阶段,即网络设计阶段。

[问题1]

简述网络规划阶段需求分析的方法和解决的问题(控制在100个字以内)。

[问题2]

在网络规划阶段"系统可行性分析和论证"的主要内容是什么(控制在100个字以内)?

[问题3]

在需求分析过程中应对已有网络的现状及运行情况作调研,如果要在已有的网络上作新的网络建设规划,如何保护用户已有投资(控制在100个字以内)?

● 试题二

[问题1]

【答案】先采用自顶向下的分析方法。

调查用户单位建网的背景、必要性、上网的人数、信息量等,从而确定建网目标。接着进行纵向的、深入的需求分析和调研,为网络设计提供依据。

[问题2]

【答案】可行性分析主要是针对用户单位具体情况,对建网的目标进行科学性和正确性论证。在此基础上提出一个解决用户问题的网络体系结构。包括网络传输、用户接口、服务器和网络管理,以及对投资及建设周期的估算。

[问题3]

【答案】在设计新系统时要充分考虑到利用已有系统的资源,让老系统纳入到新系统中运行,不要"推倒重来"。也可以把已有系统的设备降档次使用。

● 试题三

阅读以下说明和Java程序代码,将应填入(n)处的字句写在答题纸的对应栏内。

【说明】

1.SMTP是发送E-mail的协议,常用以下5条命令发送E-mail:

·HELO,与SMTP服务器握手,传送本机域名;

·MAILFROM:,传送发信者的信箱名称;

·RCPTTO:,传送接收者的信箱名称;

·DATA,发送邮件数据(包括信头和信体);

·QUIT,退出与SMTP服务器的连接。

2.试题中直接利用的类及方法如下:

(1)类ServerSocket(int port)实现TCP服务器接口(socket),它提供两种构造函数,用它们来指定服务器插口所用的端口,并监听到达的连接请求。类中的主要方法有:

accept( ):启动服务器插口监听并等待,直到建立连接为止,一旦建立连接就返回Socket类的一个对象。

getInetAddress( ):返回插口所连接的主机地址。

getLocaIPort( ):返回在服务器插口上建立了连接的端口。

close( ):关闭服务器插口。

(2)类InetAddress包装了Internet地址。类中的主要方法有:

getLocaIHost( ):返回一个代表本机Internet地址的InetAddress对象。

getaddress( ):获得数字表示的IP地址。

getHostName( ):获得域名。

(3)类Socket实现基于连接的客户插口。类中的主要方法有getInetAddress( ):返回一个与插口连接的客户机的Internet地址,其类型为InetAd-dress。getInputStream( ):用来访问与插口相关的输入流。getOutputStream( ):用来访问与插口机关的输出流。close( ):关闭插口。

(4)readLine( )是输入流类的一个方法,用于服务器或客户从对方读入一行输入流信息。

(5)用户自定义类NVTInputStream(InputStream inStream, OutputStream outStream)实现了网络虚拟终端输入接口。

(6)用户自定义类NVTOutputStream(OutputStream outStream)实现了网络虚拟终端输出接口。

3.下面是用Java语言实现的一个简单SMTP服务器程序的部分代码。

【程序代码】

import java.net. * ;

import java.io. * ;

import jdg.yan.NVTInputStream;//用户自定义类包

import jdg.yan.NVTOutputStream;//用户自定义类包

public class SMTPServer App

{

public static void main(String args[ ])

{

SMTPServer server=new SMTPServer( );

server.run( );

}

}

class SMTPServer

{

static final int HELO=1;

static final int MAIL=2;

static final int RCPT=3;

static final int DATA=4;

static final int END _DATA=5;

static final int QUIT=6;

static final int FINISHED=9;

NVTOutputStream out;

NVTInputStream in;

String hostName;

public SMTPServer( )

{

super( );

}

public void run( ){

try {

ServerSocket server= (1) ;//在1145号端口建立TCP服务器插口

int localPort=server.getLocalPort();//监听连接端口

hostNama= (2) ;//获取本地主机域名

System.out.println("listening on port"+localPort+".");

boolean finished=false;

do {

Socket client= (3) ;//监听等待,直到建立连接,返回对象client

String destName= (4) ;//获得所连接的客户主机IP地址的域名

int destPort=client.getPort (); //所连接的客户主机端口号

System.out println("Accepted connection to"+destNama+"on port"+destPort+".");

//控制台显示连接

out=new NVTOutputStream(client.getOutputStream());

in=new NVTInputStream( (5) ); //建立与连接关联的输入流

(6) ;//接收邮件

(7) ;//关闭连接对象

}while(!finished) ;

}catch (UnknownHostException ex) {

System.out.println("UnknownHostException occurred.");//出错处理

}cath(IOException ex) {

System.out.println ("IOException occurred.");

}

}

void getMail(){//实现SMTP的子集,从客户接收邮件

out.println("Server220"+hostName+"Ready!");

int state=HELO;//设置状态为HELO,state保存与客户通信的状态

do{//接收并处理从邮件客户接收到的命令

String line="";

out.println("Server 250 HELO,OK!");

try{

line= (8) ;//从虚拟终端读取一行

if(line==null) state=FINISHED;

}catch(IOException ex){

System.out.println("Server IOException occurred.");

System.exit (1) ;

}

switch(state){

case HELO:

if( (9) )//若该行信息为传送本机域名

{

out.println("Server 250 Hello");

System.out.println(line);

state=MAIL;

}else{

out.println("Server 500 ERROR");

System.out.println("Server"+line);

}

state=FINISHED;

break;

case MAIL://省略代码

case RCPT://省略代码

case DATA:

if( (10) )//若该行信息为发送邮件数据

{

out.println("354 mail input;end withCRLF.CRLF");

System.out.println(line);

state=END_DATA;

}else{

out.println("500 ERROR");

System.out.println(line);

}

break;

case END_DATA;//代码省略

case QUIT://代码省略

}

}while(state!=FINISHED);

}

//判断客户收到的命令是否与指定的命令字符串相匹配

boolean commandIs(String s,String line){

int n=s.length( );

if(s.equalsIgnoreCase(line.substring(0,n)))return true;

return false;

}

}

● 试题三

(1)【答案】new ServerSocket (1145)

【解析】建立TCP服务器插口,并指定是在1145号端口。

(2)【答案】InetAddress.getLocalHost ().getHostName ()

【解析】获取本地主机域名。

(3)【答案】server.accept ()

【解析】监听等待建立连接,返回对象client。

(4)【答案】client.getInetAddress ().getHostName ()

【解析】获得所连接的客户主机IP地址的域名。

(5)【答案】client.getInputStream (),out

【解析】建立与连接关联的输入流。

(6)【答案】getMail ()

【解析】接收邮件。

(7)【答案】client.close ()

【解析】关闭连接对象。

(8)【答案】in.readLine ()

【解析】从虚拟终端读取一行。

(9)【答案】commandIs ("HELO",line)

【解析】若该行信息为传送本机域名。

(10)【答案】commandIs ("DATA",line)

【解析】若该行信息为发送邮件数据。

● 试题四

阅读以下说明,回答问题1、问题2、问题3和问题4。

[说明]

短消息是指简短的字符信息,在短消息通信系统里,则指由短消息实体发起,通过移动网络传输到指定目的地址的有限长度的文本信息,近几年,短消息服务得到广泛应用。基于web的短消息服务平台的系统结构如图3所示。Web客户端访问Web Server上的短消息服务平台;短消息收发接口通过CMMP协议于短消息网关通信,网关服务器通过SMMP协议于短消息中心通信,短消息中心通过移动网络收发短消息。网关服务器通常可以采用两种方法:

(1)采用SP(互联网上的业务提供这)直接与某一个SMSC连接,由SMSC直接通过信令网发送短消息给用户。

(2)采用短消息网关的方式。当采用第一种方式时,在SP的短消息业务量很大时,全部短消息都与sp直连的SMSC转发,造成该SMSC负荷极大,难以满足业务发展的需要。其次,GSM网的规范做法是由用户归属地的SMSC负责用户短消息的转发,若该SMSC与提供服务的SP没有连接,当用户采用手机点播申请短消息服务时,上行短消息将无法发送到该sp。

因此,随着短消息业务的发展,并且使用GSM网的规范做法,必须采用第二种方式即通过网关方式,才能将大量SP接入到各地的SMSC上,才能保证接入的一致性即安全性,为用户提供优质服务。在这种方式中,短消息网关作为专业化的信息分配及管理者实现SP与SMSC之间的交互。

[问题1]目前,国内短消息服务平台按照接入方式主要可分为哪两种?

[问题2]请简要说出网关服务器与短消息服务过程。

[问题3]Web 服务器与用户计算机通过TCP/IP网络上进行通信,服务器端与短消息网关(ISMG)进行通信。请指出它们的通信协议。

[问题4]彩信"多媒体信息(MMS)"的别称,用户可以通过彩信功能想手机或电子信箱发送带有图片和声音的内容的短消息,文字容量可达15000字左右。请问发送MMS需要什么条件?

● 试题四

[问题1]

【答案】目前,国内的短消息服务平台按照接入方式主要可分为基于web和基于企业内部PC端两种。

[问题2]

【答案】短消息中心将用户发送的短消息内容发给与其相连的短消息网关,短消息网关根据短消息发送号码即SP的服务代码,将短消息内容发给相应的SP。用户接收短消息业务即MT业务,如图片下载等,提供此项业务的SP将短消息内容发给与其连接的短消息网关,短消息网关根据用户手机号段,发给用户归属的短消息中心。

[问题3]

【答案】web 服务器与用户计算机通过TCP/IP网络上的HTTP协议进行通讯;服务器端通过CMPP协议与短消息网关(ISMG)进行通信。

[问题4]

【答案】彩信需要GPRS高速网络的支持,同时也需要收发双方的手机都支持彩信功能。

● 试题五

NAT英文全称是"Network Address Translation",中文意思是"网络地址转换",它是一个IETF(Internet Engineering Task Force,Internet工程任务组)标准,允许一个整体机构以一个公用IP(Internet Protocol)地址出现在Internet上。顾名思义,它是一种把内部私有网络地址(IP地址)翻译成合法网络IP地址的技术,如图4所示。

某公司通过专线上网,申请的合法Internet IP地址段为192.1.1.1~192.1.1.10,使用路由器的NAT功能进行地址转换,具体配置如下:

Current configuration:

version 11.3

no service password-encryption

hostname 2501

ip nat pool aaa 192.1.1.2 192.1.1.10 netmask 255.255.255.0

ip nat inside source list 1 pool aaa

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

ip nat inside

interface Serial0

ip address 192.1.1.1 255.255.255.0

ip nat outside

no ip mroute-cache

bandwidth 2000

no fair-queue

clockrate 2000000

interface Serial1

no ip address

shutdown

no ip classless

ip route 0.0.0.0.0.0.0.0 Serial0

access-list 1 permit 10.1.1.0.0.0.0.255

line con 0

line aux 0

line vty 0 4

password cisco

end

[问题1]NAT按技术类型分为哪3种转换方式?

[问题2]请解释画线部分内容含义?

[问题3]此配置中采用了那种转换方式?

● 试题五

[问题1]

【答案】NAT可以分为静态地址转换和动态地址转换和复用动态地址转换3种方式。

[问题2]

【解析】Current configuration:

version 11.3

no service password-encryption

hostname 2501//路由器名称为2501

ip nat pool aaa 192.1.1.2 192.1.1.10 netmask 255.255.255.0//内部合法地址池名称为aaa,地址范围为192.1.1.2~192.1.1.10,子网掩码为255.255.255.0

ip nat inside source list 1 pool aaa//将由access-list 1指定的内部本地地址与指定的内部合法地址池aaa进行地址转换。

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

ip nat inside//指定与内部网络相连的内部端口为Ethernet0

interface Seria10

ip address 192.1.1.1 255.255.255.0

ip nat outside

no ip mroute-cache

bandwidth 2000//带宽为2M

no fair-queue

clockrate 2000000

interface Seriall

no ip address

shutdown

no ip classless

ip route 0.0.0.0 0.0.0.0 Serial0//指定静态默认路由指向Serial0

access-list 1 permit 10.1.1.0 0.0.0.255//定义一个标准的access-list 1以允许10.1.1.0网段,子网掩码的反码为0.0.0.255的内部地址可以进行动态地址转换

line con 0

line aux 0

line vty 0 4

password cisco

end

[问题3]

【答案】此配置中nat采用了动态地址转换。

【编辑推荐】

  1. 2010年软考网络工程师试题及答案解析
  2. 网络工程师面试需掌握四类知识
  3. 网络工程师职业发展的道路应该怎样走?



分享到:

  1. 勇闯IT培训黑色围城
  2. 警剔虚假IT认证培训的伎俩

热点专题

更多>>

读书

Java程序员面试宝典
本书是程序员面试宝典系列中的一册,也是上一本《程序员面试宝典》的姊妹书。本书对程序设计面试中Java常见的题型和常用解答技巧

51CTO旗下网站

领先的IT技术网站 51CTO 领先的中文存储媒体 WatchStor 中国首个CIO网站 CIOage 中国首家数字医疗网站 HC3i 51CTO学院